North American Telecommunications Congestion
Incident Report for InstantConference Status Page
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 15:52 UTC
Monitoring
Some customers have reached out after experiencing issues when joining a conference call via telephone. Please note that our phone bridges and related network have the capacity to handle the increased call volume and that any issues are related to capacity on the North American telecom network at large.

The vast majority of phone calls are successfully connecting, and we strongly recommend continuing to dial back in if you experience issues getting through.

Given the circumstances, and to further increase success of your calls, here are some tips to help ensure important calls are successful:

- Schedule calls at non-peak times (ie. 11:20am versus 11:00am)
- Schedule calls earlier in the morning (ie. 8am)
- Schedule calls later in the day (ie. 4pm onward)

Additionally, we are in constant communication with the main carriers in Canada/US who are responsible for core telecommunications infrastructure. We are doing everything we can to keep you connected.
Posted Mar 19, 2020 - 15:52 UTC
This incident affected: Join calls by phone.